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Features

• Cyclone IV FPGA
• 16MB of PSRAM memory
• High quality 6-layer PCB with hard gold surface finish
• Built-in CD-ROM² core
• Arcade card functions
• In-game menu
• Multi slot save states
• Ten no Koe 2 saves support
• Cheats
• Custom menu themes
• Switchless region auto detection
• Built-in firmware installer
• USB port for development

In new firmware versions, some features may be added, changed or
removed. Please refer to the latest online manual for the latest

information.

https://krikzz.com/pub/support/turbo-everdrive/pro-series/turbo-ed-pro-manual.pdf

https://krikzz.com/pub/support/turbo-everdrive/pro-series/turbo-ed-pro-manual.pdf


File Manager

• I – Open directory or file menu
• II – Back or close
• Select – Open main menu
• Run – Run last played game
• Left/Right – Switch page during file navigation

The upper bar shows the current page and total number of pages in the current folder.
The bottom bar shows the full name of the selected file.



File Menu

The file menu is used for manipulating files on the SD card. The menu content is different 
depending on the file type selected.

Rom file menu
This menu is applied to pce, sgx, cue file extensions.

Start Game
The cartridge will be configured to play the selected game. Right after the configuration is 
completed the game will be executed. After reset or power cycle of the console the last 
selected game can be launched with the Run button.

Cheats
Edit cheat codes for the selected file.

Rom Info
Shows the ROM configuration including: mapper type, checksum, memory configuration, etc.



Hex View
Opens the selected file in a hex viewer.

Delete
Deletes file from disk. Empty folders can be deleted also, hit I inside of empty folder to call the
folder menu.

Text file menu
This menu is applied to *.txt file extension.
It is used for loading cheats from text file. Loaded cheats will be applied to last selected game.

Theme file menu
The *.bgr files contain custom graphic themes for the cartridge menu.



Bram memory file menu
The *.brm files contains CD-ROM² or Ten no Koe 2 save data. The "File" menu allows you
to copy data from/to an external CD-ROM² or Ten no Koe 2 if either device is connected. This 
menu does not appear if nothing is connected to the expansion port.

Save-state file menu
This menu allows to view save state files. User can view the screenshot of the point where 
state was saved.



Main Menu

Press Select to open main menu.

Options

Options->In-Game Menu
Controls in-game menu and save state functions.

Options->Cheats
Switch on/off cheat functions.

Options->Reset Delay
OFF: System will return back to the menu immediately after reset.
ON:  Short reset hit if In-Game menu turned on: open In-Game menu. Short reset hit if In-
Game menu turned off: reset the game. Long reset hit: return to the menu.

Options->Default EXP Device
OFF: Turn off all cores.
CDROM: Enable CD-ROM² core
TNK2: Enable Ten no Koe 2
This option specifies the core that will be connected to the virtual expansion port. Games can 
override this option if they require a specific configuration to work. For example CD based 
games always activates CD-ROM core. This option valid for games that shows "EXT Type: 
default" in Rom Info menu.



Options->Last Game Autoboot
At cold system start the menu will be skipped and the last played game will be launched 
automatically, just like the boot with regular cart. Use the reset or in-game menu to return to 
the cartridge menu.

Options->File Sorting
Controls file list sorting. Max amount of files per folder is 1024 if sorting is enabled or unlimited
if disabled. Sorting may slow down while entering the folders with large amount of the files 
inside.

Options->Audio options

Audio options->Preset
Predefined sound configurations for best audio quality with various console models.
CORE DIN: For using with A/V out. Suitable for CoreGrafx and SuperGrafx.
CORE EXP: For using with expansion board. Suitable for CoreGrafx and SuperGrafx.
TG16 EXP: For using with expansion board. Suitable for TG16 and white PC Engine.
DIRECT: Raw output without any modifications.

Audio options->Audio Output
Set to mono for using regular console A/V output, set to stereo for using with A/V output at 
expansion port. Stereo audio requires an expansion board with custom audio circuitry designed
specifically for EverDrive.

Audio options->Volume L
Left channel volume.

Audio options->Volume R
Right channel volume.

Audio options->CDDA Vol
CD CDDA audio volume. 

Audio options->PCM Vol
CD ADPCM samples volume.

Audio options->PCM Filter CUT
CD ADPCM low pass filter cutoff frequency. 

Audio options->PCM Filter Gain
CD ADPCM low pass filter gain. It changes the filter curve.



Options->In-Game Combo
The controller hot-keys for In-Game menu and save state can be changed here. Two or more 
buttons should be used for the combo. Hold Run to switch-off the combo.
“Save Key” and “Load Key” are used for quick save/load. This type of saves skips in-game 
menu. “Menu Key” is used for in-game menu.
In-Game Menu option must be enabled for using any save state functions including quick 
saves.

Recently Played
Lists recently played games for fast access.



Cheats
Edits cheat codes for the last selected game. The bottom bar shows the name of the ROM that 
game codes will be applied to. Each game may have its own set of codes, they are saved in 
edturbo/gamedata folder as a text file and loaded automatically when game is played. Up to 16
codes can be applied at the same time. An alternative way to edit the codes for a certain game
is to use file menu, just select the game in file manager and hit “cheats” in file menu. Cheats 
also can be loaded from a text file selected in file manager. MagicEngine cheats export from txt
files are supported. Left column contains code address and data, right column contains 
optional description. Push Left/Right to enable/disable codes. Codes can be modified during the
game using In-Game menu. Using cheats can cause game glitches because every enabled code
steal a small amount of CPU time, the more cheats activated, the more CPU time stolen. It is 
good practice to keep as few codes enabled at the same time as possible.

System Folder
Go to the system folder. The system folder is hidden in the file list, this is the only way to open
the system folder using the cartridge menu.



Device Info
Information about the system.

• Cartridge Type: Cartridge name
• Firmware Version:  Cartridge software version
• Firmware Date: Firmware build date
• System Type: Console model
• EXP Device: Indicates if something is plugged into the console expansion port or if the 

console has a built-in CD-ROM
• Manufactured: Cartridge manufacture date
• Serial Number: Unique serial number
• Games Played: Played games counter

Diagnostics

The diagnostics menu checks cartridge health. All tests should be passed successfully if 
everything is fine. 



In-Game menu
Allows to return to menu or save the game at any point. During game play hit Save-State 
combo on the controller to open In-Game menu. Push Select for selected Save-state preview.

• Save State: Save game state. System snapshot will be immediately saved on SD card 
in edturbo/gamedata folder

• Load State: Load game state
• Restore Last Save: Load from backup the state file that was overwritten by the last 

"Save State" operation. Useful in case a save file has been accidentally overwritten.
• Restore Last Load: Load the state that was before the last "Load State" operation. 

Useful if the "Load State" operation was performed by accident.
• Cheats: Editing cheat codes for the current game
• Reset Game: Reboot the game
• Exit Game: Return to cartridge menu

CD-ROM² core

The cartridge has a built-in CD-ROM² core, which allows you to play CD images without the 
actual CD-ROM². 

Supported formats
Supported bin+cue, cue+wav and multi-bin images. Sometimes bin images can be stored as 
img or iso, they can be played without renaming. Each CD image should be stored in a 
separate folder.

Run the ROM paired with the CD image.
The cartridge can run a specific CD image with a ROM file instead of using the regular BIOS 
from the system folder. Just place the ROM file in the CD image folder. This feature is 
extremely useful for some CD games that require certain BIOS versions to work, or for hacks 
that use the CD hardware to improve audio.

CD bios (System Card)
CD-ROM² core requires the original CD bios files. These files are not supplied with the cartridge
software and must be provided by the user. The bios should be stored in the edturbo/bios 
folder. If there is more than one file in the folder, the user must use the file menu to specify 
which file to use as bios, otherwise the system will use the first file in the list. It is 
recommended to use the Japanese "Super CD-ROM System v3.0" as BIOS, this version has the
best game compatibility. You can also place the bios file inside the CD-image folder, in this 
case, when starting this game, the bios from the game folder will be loaded instead of the bios 
from the system folder.



CD game saves
Each game has its own copy of the CD backup memory. They all stored in edturbo/gamedata.

Arcade card function

This feature works for both the built-in CD-ROM² core and external CD. To use it with an 
external CD, launch the Super System Card v3 file from the cartridge menu. For built-in CD-
ROM² core this feature always enabled if Super System Card v3 is used as the bios.

Menu Themes

Cartridge supports user interface customization. Few basic themes stored in the system folder. 
Use the theme maker tool to create your own themes: https://krikzz.com/pub/support/turbo-
everdrive/pro-series/turbotheme/

Ten no Koe 2

Ten no Koe 2 provides save support for games that support saving to CD-ROM memory, 
Populous for example. Set the “Default EXP Device” option to “TNK2” or “CDROM” to make 
sure this feature is enabled.

Firmware Update

Cartridge allows you to update the firmware using the efu file. Just run the efu file from the 
cartridge menu and wait a minute. During the firmware update cartridge will update the 
internal firmware installer and extract new firmware files to the SD card. If necessary, the 
cartridge allows you to roll back the firmware to older versions.
New firmware versions can be downloaded from our website: 
https://krikzz.com/pub/support/turbo-everdrive/pro-series/firmware/

https://krikzz.com/pub/support/turbo-everdrive/pro-series/firmware/
https://krikzz.com/pub/support/turbo-everdrive/pro-series/turbotheme/
https://krikzz.com/pub/support/turbo-everdrive/pro-series/turbotheme/


Built-in firmware installer

Cartridge still runs its software from the SD card, just like EverDrive versions, but Turbo 
EverDrive PRO also has a built-in firmware installer that runs if no firmware files are found on 
the SD card. This feature frees the user from having to download and write system files to the 
SD card before starting work with the cartridge.

Firmware Recovery

Download recovery-fw.zip from the firmware update folder and extract it to a SD card. Try 
starting the cartridge. If the cartridge starts, then you can try to reinstall the firmware from 
the efu file. If it is not possible to start the cartridge from the SD card, then connect the 
cartridge via usb, unpack recovery-fw.zip on the computer, and run recovery-usb.bat.

Switchless region auto detection

Unlike older versions of the cartridge, Turbo EverDrive PRO does not have a physical switch for 
the console region, cartridge detects console region automatically. If the cartridge is 
transferred from TG16 to PCE or visa versa, the first start of the cartridge takes a couple of 
seconds longer than usual due to region switching.

System folder structure

/edturbo system root.
/edturbo/bios CD bios folder.
/edturbo/gamedata Game saves and cheats. Each game has own sub folder.
/edturbo/syscore System core files.
/edturbo/sysdata System stores its settings and temporary files in this folder.
/edturbo/themes Few basic themes examples.
/edturbo/menu.dat Menu application.

Limitations

• The built-in CD-ROM² core does not work if a CD-ROM or Ten no Koe 2 is connected to 
the console's external expansion port, or if the console has a built-in CD-ROM. For this 
reason, the cartridge cannot run CD games on Duo systems.

• CD audio is output to the console's standard A/V port in mono. To get stereo, you need 
to connect a special card with stereo sound support for EverDrive to the expansion port 
of the console.

• Save States does not work for CD or SGX games.

• For some games In-Game menu controller combos dos not work, try to use cartridge 
button in this case.

• Save states does not work perfect in all games, using this feature may cause the game 
to crash. With real hardware, it's simply impossible to make it work better.

• We do our best to ensure that our cartridge are compatible with various console clones 
and modified systems, but we cannot guarantee compatibility with all of them, 
especially modern clones released after our device.


